باگ امنیتی در افزونه ی فایل منیجر وردپرس

امروزه طراحی سایت با استفاده از وردپرس به دلیل سهولت و امکاناتی که وردپرس و پلاگین های آن  در اختیار کاربران قرار میدهند ،بیش از گذشته مورد استقبال قرار گرفته است. به  دلیل اینکه افراد بیشتری از وردپرس و سیستم های مدیریت محتوای آماده جهت طراحی وب سایت خود استفاده میکنند، هک سایت های وردپرسی بیشتر مورد استقبال قرار گرفته است و هکر ها همواره در حال تلاش برای یافتن باگ برای هک کردن این سایت ها هستند.  به همین دلیل همواره به روز بودن پلاگین ها و وردپرس اهمیت ویژه ای دارد.
یکی از افزونه های محبوب وردپرس،افزونه File Manager است که به کاربران این امکان را می دهد تا پرونده ها را به راحتی از وردپرس مدیریت کنند ، در حال حاضر در بیش از 700000 سایت وردپرسی این افزونه نصب شده است.

به گزارش شرکت امنیت وردپرس Wordfence،این افزونه باگ امنیتی بر روی تمام نسخه های بین 6.0  تا 6.8  را دارد.که توسعه دهندگان این افزونه،به سرعت نسخه 6.9 را ارائه داده اند و در این نسخه آسیب پذیری را اصلاح کرده اند.

هکرها به طور فعال از این آسیب پذیری مهم در اجرای کد از راه دور در افزونه File Manager WordPress استفاده می کنند، که با استفاده از آن می توانند اقدام به بارگذاری اسکریپت ها و اجرای کد دلخواه در سایت های وردپرسی که از نسخه های آسیب پذیر این پلاگین استفاده می کنند، نمایند.

شرکت امنیت وردپرسWordfence اعلام کرده اند طی چند روز گذشته بیش از 450،000 تلاش برای بهره برداری از این آسیب پذیری را مسدود کرده اند و شاهد حمله مهاجمان برای تزریق پرونده های تصادفی هستند که به نظر می رسد همه آنها با کلمه “hard ” یا “x” شروع می شوند.

از داده های حمله فایروال Wordfence ، به نظر می رسد که هکرها ممکن است با استفاده از این آسیب پذیری، پرونده های خالی را جستجو کنند و در صورت موفقیت ، ممکن است یک فایل مخرب را تزریق کنند. در اینجا لیستی از برخی از پرونده هایی که مشاهده شده  بارگذاری شده اند، اعلام میگردد:

hardfork.php

hardfind.php

x.php
feoidasf4e0_index.php
6ea6623e8479a65e711124e77aa47e4c

connector.minimal.php

_index.php

 

در نظر داشته باشید این اسامی،اسامی مشاهده شده هستند و ممکن است در هر سایتی با نام های متفاوت کد مخرب اپلود شده باشد.

هکرها در تلاشند تا فایل های PHP را با پوسته های مخفی شده در تصاویر در مسیر

wp-content / plugins / wp-file-manager / lib / files /

بارگذاری کنند.

کارشناسان پویاسازان اکیداً توصیه می کنند افزونه File Manager ، به آخرین نسخه (نسخه 6.9) به روز شود.همچنین تمامی پلاگین ها، تم و وردپرس شما به آخرین نسخه به روز رسانی شود.

به گزارش وردفرنس ،خبر خوب این است که فقط 51.5٪ از کل سایتهایی که افزونه File Manager وردپرس را اجرا می کنند از نسخه اسیب پذیر استفاده میکنند.
در صورتی که سایت شما با این باگ مورد حمله قرار گرفته است توصیه میشود هاست وردپرس خود را ریست و از ابتدا سایت را طراحی نمایید،زیرا هکرها با استفاده از این باگ backdoor های زیادی در سایت حتی دیتابیس قرار میدهند و مستلزم پاکسازی کامل میباشد.

در نظر داشته باشید اگربا استفاده از این باگ هک شده باشید و تنها این افزونه را حذف کنید مشکل برطرف نمیشود و لازم است سایت به صورت کامل و دقیق پاکسازی شود.

خلاصه :

طبق گزارش  Wordfence باگ امنیتی موجود در افزونه File Manager باعث اسیب پذیری حدود 51 درصد از سایت های وردپرسی شده است که از این افزونه استفاده می کنند و لازم است سریعا این افزونه به اخرین نسخه اصلاح شده،  اپدیت شود .

در صورت هک توسط باگ موجود در این افزونه ممکن است ملزم به طراحی مجدد وب سایت خود شوید زیرا این باگ امکان اجرای اسکریپت های مختلف با وجود backdoor های متعدد را دارد و در صورت هک ممکن است پاکسازی سایت کار بسیار دشواری باشد.

مطالب مرتبط

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.