چگونه خطایی Your PHP Installation Appears to Be Missing the MySQL Extension Which Is Required by WordPress را برطرف کنیم ؟

 

آیا تا به حال در زمان نصب ورد پرس و یا مشاهده سایت خود با خطایی Your PHP installation appears to be missing the MySQL extension which is required by WordPress. مواجه شده اید ؟

مانند همه  پیام های  خطای وردپرس ، مواجه شدن با مشکلی که از استفاده / دسترسی به سایت وردپرس شما جلوگیری می کند ، ناامیدکننده است.

با این حال ، ناامید نشوید!

به طور کلی ، این خطا به این معنی است که مشکلی در کد سایت شما رخ می دهد و چیزی مانع از اتصال وردپرس به پایگاه داده MySQL می شود.

در این مقاله ، ما به بررسی آنچه ممکن است باعث این مورد  باشد می پردازیم و نکاتی را در مورد نحوه عیب یابی و رفع این پیام خطا به اشتراک می گذاریم.

چه عواملی باعث از دست رفتن افزونه MySQL و خطا در وردپرس می شوند؟

همانطور که در مقدمه ذکر کردیم ، پیغام خطای ” Your PHP installation appears to be missing the MySQL extension which is required by WordPress ” از برخی مشکلات در کد / اسکریپت های موجود در سرور شما خبر می دهد.

به طور خاص ، این خطا بدان معنی است که PHP در سرور شما پسوند لازم برای اتصال سایت WordPress شما به پایگاه داده MySQL را ندارد.

دو دلیل اصلی برای این خطا ممکن وجود داشته باشد:

  1. شما از یک نسخه قدیمی وردپرس با ورژن php بالای 7 استفاده می کنید

اگر از نسخه بسیار قدیمی وردپرس با نسخه جدید PHP استفاده می کنید ، ممکن است با این خطا روبرو شوید زیرا PHP 7.0 پسوند MySQL را به نفع MySQLi منسوخ کرد. یعنی ورژن های بالای  PHP 7 دیگر شامل پسوند MySQL که وردپرس به دنبال آن است نیست.

در عوض نسخه های جدید  وردپرس از پسوندهای PDO_MySQL یا MySQLi جدیدتر استفاده می کنند. با این حال ، نسخه های قدیمی وردپرس (زیر نسخه 3.9) ممکن است این مشکل را ایجاد کند.

  1. شما از PHP 5.6 یا پایین تر استفاده می کنید اما پسوند موجود نیست یا به طور نامناسب پیکربندی شده است.

دلیل احتمالی دیگر این است که شما از PHP 5.6 استفاده می کنید (قبل از اینکه پسوند MySQL منسوخ شود) ، اما پسوند یا از بین رفته است یا به طور نامناسب پیکربندی شده است.

نحو رفع خطا

اکنون که می دانید چه خبر است ، بیایید نکاتی را در مورد چگونگی عیب یابی و رفع مشکل مرور کنیم.

  1. بررسی کنید  از چه نسخه ایPHP استفاده می کنید.

اولین مرحله برای تشخیص این مسئله این است که بفهمید کدام نسخه از PHP در سایت WordPress شما در حال اجرا است.برای بررسی  این مورد می توانید از فایل phpinfo.php استفاده  کنید. در شاخه اصلی سایت  خود یک فایل  با نام  phpinfo.php ایجاد کنید و قطعه کد زیر را  در ان قرار دهید و  فایل را  ذخیره نمایید.

<?php

phpinfo();

?>

حال در مروگر خود ادرس yoursite.com/phpinfo.php را وارد کنید  تا صفحه مربوط به اطلاعات  هاست به شما نمایش داده شود.(نام سایت خود را جایگزین yoursite.com نمایید)

شما باید صفحه ای را ببینید که اطلاعات مختلفی درباره پیکربندی PHP در سرور شما نمایش می دهد. به بخش Core بروید و به دنبال مورد نسخه PHP بگردید. به اعداد توجه کنید – باید چیزی مانند x.x.x را ببینید. به عنوان مثال. 7.2.25 یا 5.6.8:

اگر نسخه PHP شما با “7” شروع می شود ، این معمولاً به این معنی است که شما باید نرم افزار وردپرس  سایت خودرا  به روز کنید. از طرف دیگر ، اگر هنوز از PHP 5.X استفاده می کنید ، ممکن است پسوند MySQL را از دست رفته باشد.

توجه – ما اکیداً توصیه می کنیم از آخرین نسخه PHP استفاده کنید. در حقیقت ، ما از نسخه های زیر PHP 7.2 پشتیبانی نمی کنیم. این نسخه های قدیمی عملکرد کندتری دارند و از آنجا که دیگر به روزرسانی امنیتی دریافت نمی کنند ، می تواند برای سایت شما خطر امنیتی داشته باشد.

  1. هسته WordPress خود را به روز کنید.

اگر سرور شما از  نسخه php 7 و بالاتر استفاده می کند ، به احتمال زیاد علت این خطا این است که از نسخه قدیمی WordPress استفاده می کنید وردپرس نسخه 3.9 یا پایین تر می تواند این خطا را ایجاد کند.

بنابراین ، رفع مشکل به روزرسانی هسته  وردپرس شما است که با ویژگی های دیگر  مانند بهبود امنیت و عملکرد نیز همراه خواهد بود.

برای ارتقاء دستی نسخه وردپرس خود ، ابتدا مطمئن شوید که از سایت خود بک اپ  تهیه کرده اید. سپس ، به سایت WordPress.org بروید و جدیدترین نسخه از نرم افزار WordPress را دانلود  کنید.

پس از دانلود  ، فایل zip را در رایانه خود استخراج کنید. سپس ، پوشه ای را که شامل تمام فایل های وردپرس است باز کنید و موارد زیر را حذف کنید:

پرونده wp-config-sample.php.

پرونده wp-config.php (ممکن است این فایل را نبینید – فقط در صورت وجود حتماً آن را حذف کنید).

پوشه wp-content.

سپس فایل های دیگر را از طریق کنترل پنل هاست و یا ftp در هاست  خود جایگزین فایل های قبلی نمایید. در صورتی که از تم و پلاگین های قدیمی نیز استفادخ می کنید نیاز است  انها را نیز به اخرین نسخه بروز نمایید

حال مجددا  چک کنید مشکل شما باید برطرف شده باشد.

  1. بررسی کنید که آیا MySQL Extension نصب شده است یا خیر

اگر سرور شما هنوز از PHP 5.6 یا پایین تر استفاده می کند ، ممکن است سرور شما MySQL Extension  مورد نیاز وردپرس را نداشته باشد.

برای بررسی اینکه آیا این مورد وجود دارد ، به پرونده phpinfo.php که در مرحله شماره 1 روی سرور خود بارگذاری کرده اید ، برگردید.

به دنبال بخشی با نام mysql یا mysqli بگردید.

اگر MySQL Extension نصب شده است ، باید شماره نسخه را در کنار Client API ببینید:

اگر نمی توانید این اطلاعات را پیدا کنید ، به این معنی است که MySQL Extension  نصب نشده است. معمولاً بهترین راه حل این است که با پرسنل  پشتیبانی میزبان وب خود تماس بگیرید و از آنها بخواهید آن را برای شما نصب کنند.

توجه – مجدداً ، ما اکیداً توصیه می کنیم از نسخه های PHP زیر 7.2 استفاده نکنید زیرا آنها دیگر به روزرسانی های امنیتی را دریافت نمی کنند و مانند نسخه های جدید عملکرد خوبی ندارند.

بهتریم راه حل برای رفع این مورد این است  که نسخه php هاست خود را به 7.2 و بالاتر ارتقاء دهید و از نسخه 5.6 و پایین  تر استفاده نکنید.

  1. اطمینان حاصل کنید که افزونه PHP به درستی پیکربندی شده است.

اگر ازنسخه  PHP 5.6 یا پایین تر استفاده می کنید و Extension  ها نیز نصب شده است ، ممکن است مسئله این باشد که به درستی پیکربندی نشده است

اپلود  یک فایل php.ini که مربوط به سرور ویندوز است و شما ان را در سرور لینوکس اپلود کرده اید و یا  مسیرهای مربوط به این  فایل  نادرست است.

می توانید مسیر  فایل php.ini خود را در فایل  phpinfo.php که قبلاً ایجاد کرده اید ، پیدا کنید:

 

ابتدا توصیه می کنیم از فایل موجود  یک  بک اپ تهیه کنید و روی سیستم لوکال خود قرار دهید  سپس ، سعی کنید فایل php.ini را حذف کنید و ببینید آیا با این کار مشکل برطرف می شود.

مطالب مرتبط

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.